Pembahasan UKK / UPK TKJ 2017/2018 Paket 2 K13 - Solusi Menarik

Pembahasan UKK / UPK TKJ 2017/2018 Paket 2 K13


Pembahasan UKK / UPK TKJ 2017/2018 Paket 2 K13 - Kali ini saya membahas soal UKK / UPK TKJ 2017/2018 Paket 2 kurikulum 2013. Topologi dari soal ini adalah sebagai berikut:

Ether 1 – Internet Gateway
Tahap paling awal yang harus kalian lakukan adalah memastikan bahwa router telah terhubung ke internet.

Masuk ke menu CLI, harap ketikkan sesuai perintah dibawah. Untuk yang menggunakan tanda # berarti itu adalah penjelasan dari perintah yang di bawahnya.

Baca Juga : Kumpulan Soal Uji Kompetensi Keahlian SMK Terbaru (Semua Jurusan)

Isi IP gateway, sekalian isi juga IP pada ether2 dan wlan1.
/ip address
add address=192.168.1.253/24 interface=ether1 network=192.168.1.0
add address=192.168.100.1/24 interface=ether2 network=192.168.100.0
add address=192.168.200.1/24 interface=wlan1 network=192.168.200.0
Selanjutnya buat rule routing, jika IP Address tidak diketahui, maka nantinya akan diteruskan ke jaringan ether1 (publik).
/ip route
add distance=1 gateway=192.168.1.1
Agar jaringan bisa mengakses internet, Anda harus menambahkan fitur NAT yang mengarah ke ether1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
Karena saat Anda mengakses menggunakan nama Domain dan bukan IP, maka Anda harus mengatur DNS seperti dibawah ini. Disini saya menggunakan DNS Google.
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
Seharusnya sekarang sudah terhubung ke internet, silahkan untuk mengecek dari PC yang terhubung ke ether 2 bisa internetan atau tidak. Jangan lupa isi ip PC dengan yang satu network dengan ether2.

Network Time Protocol
Secara bawaan waktu pada Router MikroTik adalah tahun 1970. NTP (Network Time Protol) adalah sebuah layanan yang berfungsi untuk menyamakan atau menyesuaikan waktu antar perangkat. NTP diatur saat router sudah terkoneksi ke internet agar bisa menyesuaikan ke waktu server internasional. Untuk mengkonfigurasinya Anda bisa ke System > SNTP Client, lalu buat seperti di bawah ini dan terakhir klik OK.


Saat ini router Anda telah terhubung dengan sistem waktu internasional, selanjutnya tinggal Anda sesuaikan dengan daerah Anda. Caranya masuk ke System > Clock kemudian klik Time Zone Autodetect dan pada kolom Time Zone Name pilih Asia/Jakarta dan klik OK. Saat ini router Anda telah memiliki waktu yang real.

Ether 2 – Modul DHCP
Sesuai dengan soal, bahwa di Ether2 disuruh membuat DHCP Server. Karena konfigurasi DHCP Server susah dari CLI, maka saya Graphic saja. Silahkan masuk ke menu IP > DHCP Server pada tab DHCP pilih DHCP Setup. Di tampilan ini silahkan pilih ether2 karena Anda akan membuat DHCP Server pada ether2


Pada pemilihan network dibiarkan saja, karena secara otomatis akan menyesuaikan dengan prefix yang Anda isi di ether2


Untuk gateway biarkan saja karena sudah otomatis akan menyesuiakan dengan IP Address yang terpasang di ether2.


Untuk address secara default mengikuti subnetting, tetapi Anda harus ubah jadi 192.168.100.2 - 192.168.100.100 karena di soal minta seperti itu.


DHCP Relay kosongkan saja, karena disoal tidak menggunakan fitur ini.


Sekarang silahkan Anda periksa pada komputer yang disambungkan ke ether2, seharusnya saat ini telah mendapatkan IP secara DHCP.

Ether 2 – Static DNS
Fitur static DNS digunakan untuk mendifinisikan domain pada router. Sehingga ketika user mengakses domain, maka akan langsung diarahkan ke tujuan tertentu. Untuk mengaturnya Anda bisa masuk ke menu IP > DNS > Static > add (+) lalu tambahkan domain serta tujuannya yaitu bsnp-indonesia.org pada Address. Sedikit catatan ketika Anda klik tombol OK atau Apply, si router akan mentranslasikan domain yang Anda masukkan ke alamat IP domain tersebut.


Sampai ditahap ini silahkan Anda coba buka www.mikrotik.com pada browser Anda, akan muncul tampilan seperti di bawah ini. Sebenarnya situs mikrotik.com sudah terarahkan ke bsnp-indonesia.org atau ke IP server bsnp-indonesia.org. Maka untuk redirect menggunakan DNS statis sebenarnya agak janggal dalam kondisi seperti ini.


Ether 2 – Blokir PING
Firewall yang akan pertama dibuat adalah pembatasan IP 192.168.100.2 – 192.168.100.50 tidak bisa melakukan ping ke Router. Karena saat ini Anda memiliki 3 IP Address pada router maka semua IP Address ini harus dimasukkan ke dalam rule.
/ip firewall filter
add action=drop chain=input dst-address=192.168.1.253 protocol=icmp src-address=192.168.100.2-192.168.100.50
add action=drop chain=input dst-address=192.168.100.1 protocol=icmp src-address=192.168.100.2-192.168.100.50
add action=drop chain=input dst-address=192.168.200.1 protocol=icmp src-address=192.168.100.2-192.168.100.50
Arti perintah di atas adalah agar paket ping (icmp) yang masuk ke router melalui IP tersebut akan di drop. Sebenarnya ada banyak cara salah satunya menggunakan address list, namun saya pilih ini karena lebih simpel untuk penggu CLI dan GUI. Sekarang coba uji dari PC Anda apakah ping ke router masih bisa atau tidak.

Ether 2 – Logging
Sebenarnya saya cukup bingung dengan perintah yang satu ini. Saya baca soal ada tertulis “Buat rule agar setiap akses ke router tercatat di logging”.


Jika log yang dimaksud adalah ketika pengguna masuk ke router, maka ini sudah ada secara default, silahkan cek log router pasti sudah ada laporan ketika pengguna masuk dengan laporan berhasil atau tidak. Nah, sedangkan jika log semua aktivitas, maka pada menu log akan ada sangat banyak sekali baris yang tercipta. Dimana nantinya baris yang akan dijadikan sebagai bahan analisa malah “tenggelam”.

Tetapi saya mencoba menangkap maksudnya, yaitu seluruh aktivitas yang masuk ke router dicatat. Jadi Anda akan membuat rule nya, tetapi satu hal yang harus Anda ketahui inti dari rule ini adalah aktifitas yang sesuai akan masuk ke dalam LOG.
/ip firewall filter
add chain=input log=yes log-prefix=login
Perhatikan di situ ada log=yes dan itulah yang menjadi fokus Anda, ketika nanti soalnya diganti atau diperbaharui semoga Anda bisa. Arti log-prefix di perintah tersebut adalah untuk memberi tanda di LOG bahwa yang menggunakan kata login sebagai prefix merupakan log yang dibuat oleh aturan firewall yang Anda masukkan.

Ether 2 – Rule HTTP dan HTTPS
Menurut saya maksud dari soal ini adalah CLIENT Network ke Internet diizinkan membuka HTTP & HTTPS saja, sedangkan membuka yang lain akan diblokir seperti PING.
/ip firewall filter
add action=drop chain=forward dst-port=80,443 in-interface=ether2 out-interface=ether1 protocol=tcp
Sekarang silahkan Anda coba akses www.google.com (80 & 443) dari peramban, seharusnya bisa berjalan dengan baik. Lalu setelah itu coba akses ke ftp://ftp.itb.ac.id/ (port 21) dan seharusnya yang menggunakan port 21 tidak bisa diakses.

WLAN 1 – Hotspot
Sebenarnya pada soal di bagian wireless tidak ada kata-kata hotspot, namun jika dilihat dari topologi ada tulisan hotspot yang di wlan1 dan non hotspot di ether2.

Sebelum membuat hotspot, Anda akan ubah dulu mode wlan1 menjadi pemancar atau AP-Bridge. Silahkan masuk ke menu Interfaces > tab interface > wlan1, kemudian pada tab wireless silahkan ganti mode menjadi AP-Bridge dan SSID menjadi Gunawan@Proxy.


Selanjutnya masuk ke menu IP > Hotspot > tab Server > Hotspot Setup. kemudian pilih antarmuka (Interface) yang akan dijadikan hotspot, menurut soal adalah wlan1.


Di tampilan selanjutnya Untuk alamat IP akan menyesuaikan dengan IP yang telah Anda isi di awal-awal pembahasan. Selanjutnya lakukan unchecklist pada Masquerade Network, ini dilakukan karena Anda sudah membuat NAT Masquerade.


Untuk settingan address pool ganti dari 192.168.200.2 - 192.168.200.254 menjadi 192.168.200.2 - 192.168.200.100 agar sesuai dengan soal.


Selanjutnya pada tampilan ini pilih Next saja, karena kita tidak punya sertifikat SSL.


Kemudian pada SMTP Server, silahkan Next kan saja, karena di soal tidak menggunakannya.


Untuk DNS akan menyesuikan dengan DNS dari router. Pada settingan ini Next saja.


Pada tahapan selanjutnya Anda diminta untuk memasukkan domain yang akan digunakan untuk mengakses portal hotspot. Contoh pada kali ini saya isi dengan gunawan.local


Tahap terakhir menentukan nama pengguna dan kata sandi yang akan digunakan untuk masuk ke dalam hotspot. Karena di soal tidak ditentukan seperti UPK tahun lalu, jadi biar mudah saya isi seperti berikut.


Jika telah selesai silahkan untuk masuk ke hotspot portal dan pastikan Anda bisa mengakses Internet.

Baca Juga : Pembahasan UKK / UPK TKJ 2016/2017 Paket 3

Wlan 1 – Proxy
Untuk mengaktifkan Proxy silahkan masuk ke menu IP > Proxy, kemudian pada tab General checklist pilihan Enable maka Proxy nantinya akan berjalan di port 8080. Pada kolom cache administrator jangan lupa mengisi gunawan@sekolah.sch.id, karena itu ada di soal.


Sampai saat ini proxy telah aktif, namun agar pengguna bisa terkena efek dari Proxy ini pengguna harus melakukan pengaturan pada perangkat mereka. Namun masih ada cara yang lain agar user otomatis terkena dampak dari Proxy yaitu dengan menggunakan bantuan rule pada firewall untuk membuat Transparent Proxy. Caranya gunakan perintah seperti berikut ini. Karena ini untuk wlan1 saja, maka pada in-interface isi wlan1.
/ip firewall nat
add action=redirect chain=dstnat dst-port=80 in-interface=wlan1 protocol=tcp to-ports=8080
Wlan 1 – Pemblokiran Situs
Pemblokiran situs bisa menggunakan Firewall atau DNS Static. Jika dilihat soal sepertinya menginginkan menggunakan Proxy. Silahkan masuk ke menu IP > Proxy > tab general > tombol access kemudian tambahkan rule baru seperti ini.


Jika telah selesai silahkan untuk membuka situs www.linux.or.id maka seharusnya tidak bisa dibuka dan muncul tampilan seperti di bawah ini.


Wlan 1 – Pemblokiran File
Untuk pemblokiran saya gunakan Proxy, maka Anda harus masuk ke menu  IP > Proxy > tab general > tombol access kemudian tambahkan rule baru seperti berikut.


Maksud dari settingan di atas adalah setiap URL yang mengandung esktensi mp3 maka akan diblokir atau ditolak. Silahkan Anda uji coba download file mp3, apakah berhasil atau tidak?

Wlan 1 – Pemblokiran Konten
Untuk pemblokiran konten tidak menggunakan Proxy, melainkan menggunakan Firewall. Jadi saat ada paket yang mengandung konten mikrotik, secara otomatis akan langsung di tolak oleh router. Untuk settingannya bisa gunakan perintah berikut.
/ip firewall filter
add action=drop chain=forward content=mikrotik
Silahkan coba ping ke mikrotik.com, jika benar seharusnya tidak bisa.

Wlan 1 – Pembatasan Waktu
Sesuai dengan soal untuk pembatasan waktu Anda akan menggunakan firewall. Perintahnya sudah saya buat di bawah ini. Ada beberapa alasan kenapa harus menggunakan 2 aturan, yaitu karena router MikroTik fungsi waktu berlaku dalam waktu 1 hari mulai 00:00:00 – 23:59:59. Maka dari itu membuat 2 aturan, aturan tersebut adalah pemblokiran dari wlan1 ke ether1 pada pukul 19:00:00 – 23:59:59 dan 00:00:00 – 07:00:00.
/ip firewall filter
add action=drop chain=forward in-interface=wlan1 out-interface=ether1 time=19h-23h59m59s,sun,mon,tue,wed,thu,fri,sat
add action=drop chain=forward in-interface=wlan1 out-interface=ether1 time=0s-7h,sun,mon,tue,wed,thu,fri,sat
Itu dia tadi pembahasan untuk UPK/UKK TKJ tahun pelajaran 2017/2018 yang menggunakan Paket 2. Memang agak sedikit membingungkan jika Anda pahami kata-katanya, tetapi sisanya tentu ada di tangan guru yang berhak mengubah soal-soal ini.

Sekian pembahasan saya kali ini, mudah-mudahan bisa bermanfaat. Jika ada pertanyaan silahkan sampaikan dikolom komentar. Selamat mencoba !!!

Berlangganan update artikel terbaru via email:

ADD YOUR COMMENTS

Post a Comment

Iklan Atas Artikel

Iklan Tengah Artikel 1

Iklan Tengah Artikel 2

Iklan Bawah Artikel